Tribes doesn't connect

I'm sure there have been plenty of other posts about this, but none that I can find (in the first few pages).

i just installed Tribes 2. 1 thing i did differently was opt out of dx8, bc i have dx9c...

when i try to launch the game, i see
"checking to see if sierra update is current..."
"unable to connect to update control servers"
"please check your internet connection"

what have i missed? Any ideas?


  • TY very much. I know it seems dumb as hell, but i didn't realize the patch wasn't included with the t2 dl. it works now!

    For your help i'll reword u with dope music ;D

    Please note, all good hip-hop is poetry written in rhyme and rhythm to a beat.
  • edited December 2009
    Although... I have already run into a new problem. 5 years later i don't remember my old account, and I have to make a new 1.

    There are 3 steps to creating a new account. I can't get passed step 1.
    It tells me to wait and try again after a few minutes. I did that 30 minutes ago.
    I'll remove this post if time resolves my issue, but until then, I'm still waiting to get connected... step 1. me and i'll show you more cool music...
  • Your old account cannot be retrieved, it was on the official T2 server before it died.

    And for your other problem, be sure your firewalls/anti-virus programs are set to "Allow Access" for T2. (Including Wind0w's shitty built-in one)
  • edited December 2009
    Alright. that worked, i'm going to have to find the exception list now...

    the reward :D
Sign In or Register to comment.