Multiple Restarts when trying to set up server and cant see server

Hi, Im trying to bring back my mod Devastation. Its been years since Ive run a server. I downloaded a clean game, did the patch, and added my mod exactly where it was before. When I run it, it looks, like it loads all the way. I don't see a heartbeat confirmed and then it will restart again and again. I am at a loss. Ive turn off the AV and think Ive opened port 28000 on my att router. Suggestions?


  • The first thing you should try when setting up a server is running it on its own (i.e. clearing DSOs and running a "Tribes2.exe -dedicated -mod Devastation" shortcut) and making sure that loads up; if it crashes, there should be an unhandled exception message (even if all it shows is a memory address) that can help pinpoint the problem.
    One common issue with older mods crashing is scripts that attempt to connect to websites/domains that no longer exist, so if you had a web connector script in the past, it may need stripped out.

    If it doesn't crash, it's likely a problem with the restarter.

    Assuming you're starting it with ispawn, what command line are you sending it? Something like this?
    ispawn.exe 28000 Tribes2.exe -dedicated -mod Devastation
    Does it receive the correct port, matching the one in your mod prefs? What's the last message you see when the server loads?
    Ispawn performs queries locally to see if the server is responding every few seconds, so if the server takes a little too long to start up, it can prematurely restart it in some configurations — I can provide you with a modified, more lenient, version if you think this is your issue.
  • If you don't see a heartbeat, something's not allowing the ping to get out or back to the master server.
    You might try shutting off the fwall for the test duration as well as dmz the ip of the server in the rooter to see if you get anywhere. If so then set the rooter to dmz the server ip and enable the server fwall and try again. SAomewhere along the line you should find the blockage.
  • Krash, I see it compiling all the way thru to the tricon stuff. It says it cant connect to the server. Check ip and port configurations. I do use the same ispawn.
  • I am making progress. It now goes all the way to "sending heartbeat". It says "cannot contact server" Is the main server address listed somewhere?
  • Once receives a heartbeat, it sends a T2 info ping back to the server on the specified host port and expects a response in a reasonable timeframe. If it doesn't get the response it'll report back with this error.

    If you type echo($IPv4::InetAddress); it'll show the address that the master server should believe you're connecting from -- if this is not accurate for whatever reason (e.g. if you have multiple network adapters) you can try binding the server to a specific address with the $Host::BindAddress prefs variable. Leave it empty to unset it if you don't have a static address or don't know what it's used for.

    In most cases however this is simply a case of the port either being unreachable or not routed to the host behind a nat. Assuming you're using the default, make sure you have port 28000 over UDP unblocked on your firewall, and have forwarded that same port to the correct host on your router.
  • Still making progress. I see it on the master servers list now. When I try to join my server from another home computer it says its connecting and then I get an unhandled exception. THoughts?
  • edited December 2019
    Here's what I am seeing on the server.

    Got challenge request
    Sent challenge response
    Connection request from: ip
    accepting connect... Client ID = 0
    Sending accept: 2100
    Got disconnect packet.
    Client 2100 Disconnected.
    Issuing Disconnect packet.

    On the other computer, I see connecting. Then nothing happens and a UE
  • The client's crashing on the first join attempt? Have you tried connecting from both the external and internal network addresses of the server? In certain configurations one or the other won't work, but usually you won't get a crash unless disconnected multiple times in sequence.

    In most cases, the first attempt should show you the error description in the disconnect message on the client.
  • yes, ive tried the external join which is just whatever is on the server list right? And then Ive tried pressing the insert key and typing in the IP address for the server. When I do that, it says its a bad challenge request, possible IP attack?
  • An unreasonable IP challenge source error is a client-initiated abort that indicates the address the server thinks you're connecting from a different address than your client says it is -- which could generally happen on joining LAN servers if either a) the server's external address (if you're connecting to it) differs from the client's or b) the devices are allocated addresses in different ranges despite being on the same LAN.

    If both the client and the server use the same external address (check the address reported at on the client machine matches the server address you're joining), you should be able to join from the internet, barring any additional routing or network issues preventing it.

    Otherwise, it's really recommended when playing on your local network to connect to the LAN address. For this to work without the external IPs matching, if your client is connecting from, the server address you're attempting to connect to must also be within the range, or else the script will think there's an attack attempt.
  • Hate to be a pain. Thanks for your time. When I go to the cmd prompt on the server, it doesn't have a lAN address. t shows the address displayed on the server list screen. When I do ipconfig on the desktop I am tryting to connect and play on, IT has a 192.168.1 90 address. Both the server and descktop are coming out of an 8 port hub which is fed from the AT&T router. I went to Starbucks, and was able to join my server and play on it. I think theres a problem with the DHCP. Would an actual router in place of a switch help? Total over my head and lost. THanks in advance.
  • If they're both being automatically allocated addresses from the same nat device's DHCP server, and you haven't explicitly configured it otherwise, they should both be in the same range, and a different router wouldn't change much other than potentially making it easier to see/control the assignments...
    Which addresses are you actually connecting to in each failed attempt? Have you tried using queryLanServers(28000); with the server list open to send a broadcast ping within your network?
  • Hi Krash, Im still having problems. I can set the server up to either have a local 192.168 type ip4 address and actually play on it. But when I do, it people cant join it. Obviously. I can also set it up on its external 75.26 type address. People can see it and join, but I cant. I remember having two ip addresses the last time I tried setting up a server. One lan and an external ip address. I have an AT&T U-verse router with several nodes for wifi. Te server is on on of the the wifi nodes and my desktop is now directly connected to an ethernet plug in the back of the router.
  • You shouldn't be setting the server address anywhere yourself if you're behind a NAT (particularly not using $Host::BindAddress, which is intended for systems with multiple network interfaces to restrict binding) -- the address the master server and anyone on the internet should use is that already assigned to your router (75.26.x.x), which should simply be configured up to forward UDP traffic on the host port to that particular machine.

    The address you should in almost every case use yourself to connect/ping the server, within your LAN, is the server's LAN address (192.168.x.x).
Sign In or Register to comment.