Need Help Playing Online

I have downloaded Tribe 2 I have downloaded the patch as well but I can't seem to be able to find any servers my firewall isn't blocking it....I think it says filter LAN and I'm wondering if that's it because I can't find a way to change the filter settings. PLEASE HELP I WANT TO PLAY!!!

:-[ :-[ :-[


  • KrashKrash Neptune Sleeps
    In order to play in online mode, you'll need to use the "Tribes 2 Online" shortcut and make an account. This should be in the same place you found the "Solo & Lan" shortcut (generally in your Start menu under "Dynamix"), but if not you can modify your existing shortcut by right-clicking, going to properties, and changing the last part of the target to: "Tribes2.exe -online"
  • I really appreciate the help I have tried to use Tribes 2 online before but it says I need to check my internet connection, I turned off the firewall and tried but to no avail any ideas would be much appreciated.
  • KrashKrash Neptune Sleeps
    If you're seeing the old Sierra update launcher when you click, you need to make sure you've installed the patch. If you haven't done so, you will be unable to play online.

    If you're getting an offline error message on the first step of account creation, check this FAQ entry for a few possible solutions.
  • Hmmm I'm still seeing the Sierria launcher, I think I made an exception in my firewall and turned it off anyway I don't really have an online anti-virus so I don't think an anti-virus is blocking it well... This is what's going on:

  • KrashKrash Neptune Sleeps
    You need to install the TribesNext patch to play online. If you're still seeing that launcher, you haven't installed it yet.
  • edited July 2011
    I swear on my dead grand mothers grave I have installed the patch lol for some reason it hasn't done anything. :S

    Output folder: C:\Dynamix\Tribes2\GameData
    Patching console_start.cs.
    Copy to C:\Dynamix\Tribes2\GameData\console_start.cs.bak
    Rename: C:\Dynamix\Tribes2\GameData\Tribes2.exe->C:\Dynamix\Tribes2\GameData\Tribes2.exe.bak
    Extract: jpatch-w32.exe
    Extract: patch.bdiff
    Patching Tribes2.exe.
    Delete file: jpatch-w32.exe
    Delete file: patch.bdiff
    Installing everything else.
    Rename: C:\Dynamix\Tribes2\GameData\SierraUp.exe->C:\Dynamix\Tribes2\GameData\SierraUp.exe.bak
    Extract: SierraUp.exe
    Extract: t2csri_eula.txt
    Extract: t2dll.dll
    Extract: rubyintersect.dll
    We know you like it.
    Extract: msvcrt-ruby190.dll
    Output folder: C:\Dynamix\Tribes2\GameData\base
    Extract: T2csri.vl2
    Created uninstaller: C:\Dynamix\Tribes2\GameData\TN_Uninstall.exe

    Edit: I have fixed it!!! It turns out that Avaast anti virus was sandboxing it, Thank you so much for your help. :)
  • Good job. And for others who have an issue like this, disable any av or firewall untill you get the game up and connected.
Sign In or Register to comment.