Troubles with Seeing Server

Hi guys, I use to run a dedicated server called Devastation. I ran it for years before T2 slowly died. I remember 1500 servers running at one point. Anyway, I ran it on a homebuilt server running Windows 2000 Pro, yes its been a while. I cant get any updates needless to say, so I copied all of my tribes files onto a newer computer running Windows Vista. LOL yes newer is a relative term. I got the ispawn.exe file to run, it looks like it loads all of the files correctly and even gets a confirmed heartbeat. The trouble is, it doesnt show up on the server lists. I know that its probably a firewall. My set up is as follows, comcast cable comes into the house, goes directly to a linksys switch, then goes up to the Comcast router from which the "newer" server has access to the internet. I have ESET mart Security on all my comps, and Comcast has its own firewall. Ive disabled both firewalls and th windows firewall but it does not help. ANy suggestions or help would be appreciated. Thanks in advance.


  • Hi, make sure your fwalls are actually down for testing. I've seen consumer routers/modems still block ports even if the fwall is down, so place the ip of the server into a dmz and enable it, that should clear up that router. Also, I've seen the same thing, heartbeat confirmed but not really. Also, in vista add t2 to the fwall list, udp and tcp both. I don't have a sys running vista right now so can' tell you particulars, you might add the port wich should be 28000 or therabouts. Also, if you have ms essentials or other antimalware you should add the app to the list of do not touch programs.
  • Hi, If you still can't get the firewall settings to work right, I can host a server on my computer but it probably won't be up 24/7. Also, I suggest putting the Devastation mod in the Tribes2 Ultimate Pack, because I can't find it anywhere else on the internet. It would be horrible if a good mod was lost forever due to it not being in there. If you would like me to host the server, post a link to the mod files on dropbox/google drive/some other hosting service.
  • It could be that the master server endpoint doesn't work under some conditions. After some debugging on my own systems suffering the same problem, I found that the master server list endpoint may not be behaving correctly. Below is a technical description, so basically tl;dr: it telling you that the server was added to the list is potentially a bug, especially if it gave you errors alongside it like "Server can't be reached". Also check and see what happens if someone tries to connect to your IP directly from (You can hit the Insert key when looking at the server list to manually add a server IP).

    It looks like the master endpoint tries to send multiple responses at once, even if they conflict or are just repeats. On my own network I have it telling me all in one response that my server can't be reached, the heartbeat was confirmed and the server was added to the list so I'm left wondering how the heartbeat can be confirmed if my server can't be reached, especially considering that the end result is the server not being listed:
    HTTP/1.1 200 OK\r\nDate: Sun, 11 Sep 2016 20:08:55 GMT\r\nServer: Apache\r\nVary: Accept-Encoding\r\nAddress:\r\nCache-Control: max-age=300\r\nExpires: Sun, 11 Sep 2016 20:13:55 GMT\r\nKeep-Alive: timeout=2, max=100\r\nConnection: Keep-Alive\r\nTransfer-Encoding: chunked\r\nContent-Type: text/html\r\n\r\n1\r\n2\r\n0\r\n\r\n

    That is what happens when I have my Tribes 2 server behind a routing box that is masquerading the incoming connections. This also causes the MITM check to fail when people try to join (via direct IP since the server isn't listed) and crash clients because of the way masquerading works and the fact that Tribes 2 has a crash bug related to dialogs being displayed too quickly. So even if the server showed up correctly under this situation, nobody can join.
    (In the \r\n\r\n1\r\n2\r\n0\r\n\r\n you see 1,2,0 appearing in that order for the endpoint response codes)

    When I rework my network to not use the masquerading and purposely make the server not reachable, I get just the server can't be reached and the server was added to the list responses, and the "Server can't be reached" response is duplicated twice.
    HTTP/1.1 200 OK\r\nDate: Sun, 11 Sep 2016 20:27:06 GMT\r\nServer: Apache\r\nAddress:\r\nCache-Control: max-age=300\r\nExpires: Sun, 11 Sep 2016 20:32:06 GMT\r\nVary: Accept-Encoding\r\nTransfer-Encoding: chunked\r\nContent-Type: text/html\r\n\r\n1\r\n1\r\n0\r\n\r\n

    (In the \r\n\r\n1\r\n1\r\n0\r\n\r\n you see 1,1,0 appearing in that order for the endpoint response codes)

    When I setup the non-masquerading network correctly, I get the same exact endpoint response as I did under the masquerading configuration but the server is actually listed correctly.

    To test the masquerading setup to be absolutely sure that the server is actually reachable, I've also setup a simple local UDP server on the machines that normally would be running the game and they are indeed receiving UDP data from the TribesNext master server probing for a live game server. Just instead of it receiving from the TribesNext server prober, it receives from my masquerading router box. The inconsistent reporting behavior is at the least pretty confusing and makes it quite a ways harder to debug and both the MITM checks & server list not working correctly on networks that might be "masqueraded" is causing headaches for people that end up in these situations.

    However, given the original poster's setup above the only relation this may have to the issue at hand is that the router isn't actually forwarding but masquerading (hence why I asked to see what happens if he has someone connect directly).
  • Well Im slowly making progress I gues. When I run ispawn.exe, it again looks like it loads and still get the heartbeat confirmed msg but I still cannot see the server when I try to play T2 on anothe computer. I looked at the "servers" link at the top of this page and it shows up. I even saw that one guy was on it playing. Very strange. I dont know anything about masquerading.
  • Any server added to the list has successfully responded to an information query identical to those made by players, using either the IP address automatically detected by the master server (reflected in the "Address" header in the response), or that which is explicitly bound by specifying $Host::BindAddress in your server preferences. A successful query means that within 5 minutes you'll be able to see the server listed on the site, and that it will be sent to players upon refreshing their lists; as the server was able to respond with the appropriate information, it's presumed that a player can obtain the same response, but there's no guarantee that they'll be able to join.

    What you're describing sounds like an internal networking issue wherein you cannot query the external address from within your network. To get around this, you can simply hit your "Insert" key and manually type in the LAN address of your server to have it attempt to query -- and if successful, mark that server as a favourite in your list. You can also attempt to query it by opening your console (~) and typing queryLANServers(28000);

    The leading and trailing lines in DX's post are chunked encoding indicators, which should be ignored, and aren't related to any operations the master server is performing; they're simply used for transaction handling and shouldn't be in use by the game code. The actual state enums in use are in the middle in those quoted responses, and indicate in the first that the heartbeat was accepted, and the second that either no response was received in time, or that it was incorrect in some way. In any case, Zamo's server did respond to the queries, and was added to the list without issue, so while it is an effect of the networking configuration, it's not related to the external visibility.
  • Thanks for the tips Krash. I typed in the local ip address for the server on my games console and lo and behold, it was there. It showed the Comcast router assigned address of I made that address static for the server on the router. I also made it a favorite in my game. My real address on the internet however is and it is not displayed. When I type that one in on the console, my server cant be found. I've tried disabling both the routers firewall and eset firewall with no change. Ive tried both addresses in the dmz without help. It is cureently running and listed on server list. At least I can play Devastation by fun.
  • GRRR...this is fustrating. Hate to keep bothering you guys, but would one of you mind trying to join Devastation? Let me know? I think i've pretty much decided that the problem is with the comcast router. It is the one assigning the lan addres.
  • Server plays fine.
  • Thanks guys, I tried to rework my network this afternoon and totally meesed it up. Just now got it back together after 100 interuptions and such. I saw Blakhart on it so It must be visible on the master list and playable. Thats what I wanted. I will just play from the lan address and be content. Thanks for all your help and input. What is the Tribes 2 Ultimate pack? Does does it use the .dso files or the .cs files?
  • The Ultimate Pack is not a precompiled pack. It just has almost everything known to Tribes 2 in it.
Sign In or Register to comment.