Windows 7 Issues: Can't install OpenGL, game crashes when level loaded

Hey, I'm not sure if there's a topic about this already, I myself didn't see one, but I'm on Windows 7, and I want to play some Tribes 2. Before I downloaded the patch, I could go to singleplayer and change settings and whatnot, but when I tried to load a level, the game crashed. I think it's because I don't have OpenGL, and I don't know of any way to get it. However, after I got the patch off the site here, I can't even start singeplayer. It just plays the error sound and nothing else happens whatsoever. Please help me. I have fond memories of this game.


  • i had the same problem... found out it was my videocard drivers... i downloaded the Nvidia 259.31 version,which has Open GL4 i believe. and everything works fine, but when i updated them again to the current ones. it no longer worked, so i had to download and reinstall the previous version again. and now its back to working just fine
Sign In or Register to comment.