Can't connect to the authentication server (it's online, T2 enabled in firewall)

As in the topic.
It seems Tribes 2 cannot connect to the internet. I can wait forever while waiting for the authentication server and nothing happens. I added Tribes 2 Onlne and Tribes 2 launcher to the exceptions in windows 7 firewalll (the only one I use, I don't have any antiviruses etc.). The window which appears when Windows asks if I want an app to have online access appeared only when I launched T2 Solo & Lan AFAIR.

Please help
Regards

Comments

  • Hiya Pete, check your pm box please.
  • Yes, I am having the same problem. Can anyone help?
  • I checked that. Is it possible that it's not working because I didn't use the torrent? Could you just make an account for me and send me the user/pass?
  • pm me your email, the name you want, and the pw you want
  • Alright I'll do that, but I tried it with another person (Disci, you may know him), and it didn't work; he made the account and gave me the info (user/pass) and when I logged in it said "cannot download the account credentials."

    Does that happen when you do it? Or will I FINALLY be able to play t2?
  • need ur email cuz u wont be able to get the credentials via the game, i must email them to you after account creation
  • ThythThyth Apotheosis Incarnate
    If you can't contact the account server to create an account, what makes you think you'll be able to connect to the same server to download authentication credentials? Emailing account credential key-files when you can't create an account yourself is a bit obtuse, especially since it frequently indicates firewall issues that will prevent communicating with the master list server once you do manage to log in.

    Almost invariably, once you get the key-files for your account from someone else, and you've "logged in", you'll be back on the forum wondering why you can't see a list of servers.

    There's something running on your system, or your network, that's blocking connectivity. It's best to find out what it is instead of blundering around it with these sorts of workarounds.
  • edited September 2020
    @Thyth: Howcome t1/vengeance and other games work fine?
  • ThythThyth Apotheosis Incarnate
    Tribes 2 with the TribesNext patch contacts a handful of different systems over a handful of different protocols. Authentication server location is looked up on a web server over HTTP. Authentication server communication itself is a proprietary new-line protocol over TCP. Master server list is located on a different web server and is retrieved over HTTP. In game chat is a TCP connection with the IRC protocol. Communication with game servers (playing and querying them) is done over a custom UDP protocol.

    When certain host side firewalls see that, they try to classify the application as a web browser type application that communicates HTTP, and drop all other communication protocols, since these subsequent communications are not HTTP. AVG is notoriously bad in this regard, and it isn't even a firewall (I'm not sure what business an antivirus program has in interfering with network communication).

    I'm including a full fledged "diagnostic" button in the next version of the patch (RC3) that will give a message indicating exactly where and what is failing when a key is pressed at the login screen, since different host side firewalls tend to break the process at different stages.

    Ultimately, any security software that interferes with the process after the executable has been added to the exemption list is broken. TribesNext patched games are just particularly sensitive to this, because the game communicates with a handful of distributed systems in a way most games don't. I've been pretty accommodating to work around these problems as they arise, but, there's only so much that can be done when facing completely insanely broken network security software.

    All of my previous points still stand.
  • Wow, thanks for replying so soon. Truth is, I don't know too much about internet protocols, but I've made exceptions for T2 on both Windows Firewall and my antivirus firewall (for both incoming and outgoing connections --> don't know if that makes much of a difference), and nothing seems to work.

    I understand that Blackhart will be sending me some sort of code or file that I will have to place in my Tribes directory so that it stores my account without me having to retrieve my account credentials.

    You're saying that after having received the account credentials and managed to log in, I will have problems querying the t2 servers. Why would that happen?
  • ThythThyth Apotheosis Incarnate
    Windows Firewall is smart enough not to cause trouble. What antivirus software are you using?

    The process the game runs to communicate with the account server isn't much different from the process that the game uses to find and communicate with the active game servers. In general, if you are having trouble with one, you'll have trouble with the other (true about 95% of the time).

    The system is designed such that you only talk to the account (authentication) server when creating an account, or when you've reinstalled the game and you want to use a previously created account. This downloads a bit of cryptographic data, which is all you really need to do a log in. If you're sent this data manually (public.store and private.store), and you install it into your game, you can perform a login without any of the network communication with the account server. This is what happens anyway if you talk directly to the account server.
  • I understand. The thing is, I've tried accessing the authentication server before (about 6 months ago) and I had exactly the same problem, only I was using another antivirus (Norton). Now I'm using Panda, but the problem still holds. I've made exceptions for tribes, but other than that, I don't know what else I could do. Any advice?
  • *sigh*

    I can login successfully, but Thyth was right. I can't ping any servers because I have no access to the authentication server. What the fuck..

    I'm betting it has something to do with my antivirus. What could it be?
  • disable it and test
Sign In or Register to comment.