Can't create/retrieve account - stuck in limbo

I tried getting a TribesNext account together aeons ago when TribesNext was new. I recall having some kind of key-related problems at the time (key generation was a little buggy way back when) and having trouble getting my account set up.

This time around, I've decided to try and get into it again, and I went through account creation. It says my username (ChampionHyena) is taken! Did I really get it registered last time?

To check, I go back to login, put in my username and password. It asks to retrieve info from the server, I say yes. It says my username and/or password are incorrect. By now I've tried every possible permutation of the password I would have used, and I'm near to certain I didn't just up and forget my password.

It seems like my account is in this weird Schrodingerian quantum state of both being registered and unregistered. Is there any way to still retrieve or delete/restart my account? I am pretty sure (judging from what I've read) that a manual password change is out of the question. What should I do?


  • If it tells you the account has been taken, then yes, it most likely did get registered when you first attempted - unless you suspect someone would register your name.

    The account is registered and stored on the server. If you can figure out the account details you can download the keypair and login using it, otherwise you might as well create a new account with a different name. "Champion Hyena" (with a space) doesn't look to be in use, if you want to try that.
  • "Retrieve Account" is greyed out--is there any way this could be causing problems? I admit I don't know what that dropdown is for.
  • No, it should be greyed out by default. The drop down is for switching between multiple accounts stored on your computer so you don't have to type in the username. The "Retrieve Account" selection adds the extra input field for downloading accounts from the server.
  • Looking at the account server database, I do see an account named ChampionHyena (GUID 2273302) with a broken key. I modified the account creation process in RC2 to require the client to sign their account creation request with the key they've just created (precisely to prevent this from happening). Due to the way the account system is set up, there's no real way to restore the name for use, despite the broken key. In any case, the account retrieval password verification is independent of the key generation process -- you just won't be able to connect to a server with the broken account key.

    I see another account: ChampionHyena1 (GUID 2615582), which perhaps you also created?
  • I do not maintain meticulous bookkeeping, it seems. I don't remember creating ChampionHyena1, but my password works for it. Memory's a little rusty, I suppose.

    Oh well. Thanks for the responses!
Sign In or Register to comment.