I can't install T2 25034 update after new install

For whatever reason T2 stopped working for me a few days ago by giving me a UE on launch. I was forced to uninstall/reinstall. When trying to run the T2 25034 update, I get the error message 'The file C:\Dynamix\Tribes2\Readme.txt is not a valid version and could not be upgraded'. The update then ceases to continue and closes out.

Nothing I've tried seems to work and although I have found through Google, someone online having had the same issue in the past, nothing is mentioned for a fix. Does anyone have any suggestions?



  • Is read only enabled in the properties for the Dynamix folder? Tried another update?
  • If you are using the tribes2gsi.exe installer (available from the tribesnext.com main page), then there is no need to install the 25034 update (it's already applied!). The only reason you would need to install the 25034 update is if you are installing from a CD or some other outdated install medium.
  • KrashKrash Neptune Sleeps
    Yep, you only need to run that update if you installed from the original 2001 CD release. Version 25034 was the final re-release update, which is pre-included on the post-2002 bestseller discs, as well as in the free tribes2gsi.exe installer we distribute and recommend.
Sign In or Register to comment.