hardware failed to switch to the specified mode

i haven't changed my video drivers for a few months but they are the most recent. i installed the game last week played a few times without any issues, no scripts, and today i get the following error. so i wiped the game out cleaned my reg and rebooted then reinstalled and i still can't get it to play. i get the error message saying "hardware failed to switch to the specified mode" right after the cmd box closes


I play on a Win Vista Home 32 with integrated IBM video card 3g ram

Problem signature:
Problem Event Name: APPCRASH
Application Name: Tribes2.exe
Application Version: 0.25034.0.0
Application Timestamp: 3dc05b85
Fault Module Name: OpenGL2D3D.dll
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 3dc05b8c
Exception Code: c0000005
Exception Offset: 00004409
OS Version: 6.0.6002.2.2.0.768.2
Locale ID: 1033
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160

Comments

  • integrated IBM video card
    ...what? You might want to read your specifications more closely.
  • Hi
    Cut and paste the dll to elsewhere outside the t2 folder and try again.
  • edited February 2010
    integrated IBM video card
    ...what? You might want to read your specifications more closely.

    re read what i said, i played fine for a few days (more like a 7 days about 20hrs a day) then all of a sudden blah. i play all the latest MMO's and FPS with out a problem. my system is more than capable of running T2. so what you are trying to say is that it ran it without a hitch for a few days purely via luck?


    Model : Pentium(R) Dual-Core CPU T4200 @ 2.00GHz
    Speed : 2GHz
    Total Memory : 3GB DDR2 SO-DIMM 2x 333MHz (666MHz)
    Video Adapter : Mobile Intel(R) 4 Series Express Chipset Family (10 SM4.0, 1.4GB DDR3, Integrated Graphics
    Wireless Adapter 1 : Atheros AR5007 802.11b/g WiFi Adapter (802.11g (ERP), TKIP, 54Mbps)
    Windows System : Microsoft Windows Vista Home 6.00.6002 (Service Pack 2)
    Hi
    Cut and paste the dll to elsewhere outside the t2 folder and try again.
    ya already tried that and nothing
  • delete all dso files in each folder inside the base folder and try again
  • ThythThyth Apotheosis Incarnate
    This is a problem with the mode switching instruction to the graphics card driver.

    I know you're not strictly getting an Unhandled Exception, but the Misc Solutions in the FAQ (see http://www.tribesnext.com/forum/index.php?topic=1337.0), specifically setting windowed mode, or setting bit depth in your prefs file to 16 or 32 bit (and/or resolution to same as your desktop display if fullscreen) should resolve this.
  • delete all dso files in each folder inside the base folder and try again
    already did that

    This is a problem with the mode switching instruction to the graphics card driver.

    I know you're not strictly getting an Unhandled Exception, but the Misc Solutions in the FAQ (see http://www.tribesnext.com/forum/index.php?topic=1337.0), specifically setting windowed mode, or setting bit depth in your prefs file to 16 or 32 bit (and/or resolution to same as your desktop display if fullscreen) should resolve this.
    i can't do this because i don't have a ClientPrefs.cs file it won't even get that far to make one. literally the cmd box closes and a get a grey screen and the error pops up.

    Gah guess i will have to install this on my other pc, it's a dinosaur but it's the one i played on back in the day
  • ThythThyth Apotheosis Incarnate
    You can create a ClientPrefs.cs file in base/prefs with the values in the FAQ.
  • To set to windowed mode:

    $pref::Video::fullScreen = "0";

    I have the same issue with my laptop, but I play windowed anyways, so that was the fix for me.
  • To set to windowed mode:

    $pref::Video::fullScreen = "0";

    I have the same issue with my laptop, but I play windowed anyways, so that was the fix for me.

    this seems to have worked for me.
Sign In or Register to comment.