TribesNext

Welcome, Guest. Please login or register.
Did you miss your activation email?


TribesNext >  TribesNext.com Forums >  Support >  New to TribesNext, Can't get patch to apply « previous next »
Pages: [1] Print
Author Topic: New to TribesNext, Can't get patch to apply
CrockettScience
Nugget
Posts: 2

View Profile
August 18, 2018, 05:15:30 PM »
Hey all,

I installed the game via the download link on the site, and downloaded the patch as well. The game downloads and installs just fine, but when I go to apply the patch, it just starts the process, hangs for a bit of the first copy step, then just closes without changing or modifying anything with no error or message. Here is the patch details right before it closes:

Output folder: C:\Dynamix\Tribes2\GameData
Patching console_start.cs.
copy to C:\Dynamix\Tribes2\GameData\console_start.cs.bak

This is on Windows 10 and the patcher runs in admin mode, and I haven't been able to find anyone else who's experienced this.

Attached files Thumbnail(s):
Click for larger version Name:Untitled.png Views: 16 Size: 97 KB
Krash
Administrator
Posts: 261

View Profile
1: August 18, 2018, 07:29:21 PM »
No changes occur whatsoever? console_start.cs.bak isn't even created?

There's nothing in the installer itself that should allow it to close on its own without showing an error message (requiring user input to exit), and this stage in particular performs only very basic file-system operations.
Unless an outside process (such as an overzealous antivirus suite) forced it to close, there's nothing that springs to mind that would cause this behaviour -- and if it's an AV suite causing issues, I would expect it to interrupt either immediately before or after this step, when detection of running processes and extraction/execution of a binary delta patcher respectively occur.

CrockettScience
Nugget
Posts: 2

View Profile
2: August 19, 2018, 10:32:37 AM »
console_start.cs.bak is definately not created, and console_start.cs does not change at all.

I can't speak to how the patcher is built but but I believe you on the error thing, and fully agree on everything else- No AV is causing anything, which is what makes this bizarre. All I got is the default Windows Defender and I already tried running it with real-time protection turned off; same result.

You said the patcher is just binary delta but is there by chance a step by step of how to patch manually? I'm a software engineer so I have an IDE and a compiler laying around and experience to do this if possible. Thanks in advance.
Krash
Administrator
Posts: 261

View Profile
3: August 19, 2018, 01:27:41 PM »
Yeah, that's pretty odd...  I suppose it's possible there's a bug with that old NSIS build that causes it to crash without warning on your specific setup.

If you want to install it manually, it should for the most part be as simple as opening the exe as an archive (e.g. with 7zip or WinRAR) and extracting the included files and base folder into your Tribes2/GameData/ directory.
You'd then want to open a command prompt and run the following to backup and apply the patch to Tribes2.exe:
Code:
rename Tribes2.exe Tribes2.exe.bak
jpatch-w32.exe Tribes2.exe.bak patch.bdiff Tribes2.exe

At that point, the only thing you'd be missing to get it running are the few line changes to console_start.cs, the diff for which was embedded in the install script; I've attached the original diff here, and you should be able to apply it with a standard patch tool (or change the lines manually if desired).

After that, just use a shortcut to "Tribes2.exe -online -mod classic" to get up to the TribesNext login screen.
Attached files
* console_start.cs.diff (0.57 KB - downloaded 10 times.)

Pages: [1] Print 
« previous next »
Jump to:  

irc.quakenet.org / #TribesNext Powered by SMF  © Simple Machines