Weird lag issues with Tribes 2

I've been having some weird lag issues with my T2 jumping around on servers. Unfortunately, it doesn't show up on a demo.

First of all, when I open up t2 online, on the warrior setup page everything is really laggy. The arrow jerks around and it takes a couple seconds to open up drop-down menus. Then, when I go to the "join" tab, that all seems to clear up. However, when I join a server, it takes forever to load, and as soon as I spawn I start warping. Big warps, like down to about 1 frame per second, although it jumps around a lot - sometimes it will give me like 1 fps, a second later I'll have 10. After a little while that clears up for a minute, but comes back on and off as long as I'm on the server. This does not appear to happen on single-player. Also, it's happened on pretty much ever server I've tried; I mostly ping about 50-90 on them.

At the same time as this is happening, is giving me 10 Mb/sec download and 2.51 Mb/sec upload, so I don't think it's simply my internet connection.

Here are the specs for my computer:

Compaq CQ50-215NR laptop
Athlon 64 X2 QL-60 1.9 GHz (dual-core)
160 GB HDD
nVIDIA GeForce 8200M G (I think it's a discrete graphics card, but I'm not sure)
Windows Vista Home Premium SP1

I've tried running the program as administrator or under compatibility modes, no luck.


  • Affinity. See the FAQ.
  • Well, gee, maybe I should read the FAQ next time. :-[
  • Ok, I did the affinity thing - I used imagecfg to patch my .exe so that it would operate only on CPU 1. That helped, but after about 5-10 minutes of playing the jittering issues always come back again. They're not as bad as they were before, but they're still there. I tried putting the .cs file in my scripts\autoexec file (I named it setPerfCounter, by the way, should I have named it something else?), and it didn't seem to help. Is there something else I should do?
  • You could try installing AMD's multi-processor "optimizer" thing.
  • edited May 2009
    Ok, I tried the AMD multi core thingy, and it didn't help. I'm running Vista, which AMD doesn't seem to have a processor driver for. The next thing I'll try is uninstalling and reinstalling T2 and letting it install directx 8.

    EDIT: That didn't help.

    BTW, I tried using SMPSeesaw to isolate T2 on one core, but for some reason Tribes2.exe didn't show up in the SMPSeesaw process list. Any ideas why?

    Also, I was talking to Abstract and he recommended that I try playing on a hard-wired connection to the router rather than a wireless link. I'll let you know how that goes when I get a chance to try it.
Sign In or Register to comment.