Tribes is not working for me.

:'( Tribes says this when I try to play "hardware failed to switch to specified mode" I downloaded dirextx8 when it told me to in the tribes installation, I have also put on the multiplayer patch


  • Hi
    Do you have a video driver installed?
    What are your system specs as far as os, vid card, etc?
  • Well, I will give you my dxdiag. Also I have windows vista. It says failed to switch to specified mode. Then a unhandled message thing.

    Here is my dxdiag:


    Name: Intel(R) G33 Express Chipset Family
    Manufacturer: Intel Corporation
    Chip type: Intel(R) GMA 3100
    DAC type: Internal
    Approx. Total Memory: 286 MB
    Current Display Mode: 1440 x 900 (32 bit) (60Hz)
    Monitor: Dell SE198WFP

    Is that enough. But if I have to change settings to my game could you walk me through it?

  • edited March 2010
    Wish I was more experienced with vista but I am not. Hopefully someone will come along that is. But i will suggest that one deletes all .dso files found inside the base folder and all folders inside base. I would also go into base/prefs and open clientprefs.cs with notepad and set the following lines:

    $pref::Interior::VertexLighting = "0";

    $pref::OpenGL::allowCompression = "1";

    $pref::OpenGL::compressionHint = "GL_FASTEST";

    $pref::Video::allowOpenGL = "1";

    $pref::Video::preferOpenGL = "1";

    $pref::Video::resolution = "1440 900 32";

    $pref::Video::displayDevice = "OpenGL";

    That is, if you are running 32bit color on your desktop, if you are running 16bit color you want the line to be thusly so the game doesn't change mode:

    $pref::Video::resolution = "1440 900 16";

    Also, in the vid card driver control panel I would disable all anisotropic filtering or antialiasing, if these are an option.

    Conversly, if the above doesn't help I would delete the clientprefs.cs file and restart the game, the game will rebuild the prefs and perhaps that will get you going, but do this last.

    Script that deltes dso files automatically on game exit:

    Mess of t2 scripts:
  • I have a feeling you are using Windows Vista. If so, these instructions may enable you to start T2. Only have to do them once and T2 works from then on.

    To fix this all you have to do is change your screen depth to (Right Click Desktop, Personalize, Display Settings) Color Depth = (Medium)16. Launch the game, close it, then switch the color depth back to 32 to get good quality, or not if your in for performance. Viola! The game works with no error.
  • I did both of what you guys said, thanks! I vote you best of the best helper, exclusing the thyth guy. ;D GREAT JOB!
  • i was having the same issue and i used the search and came a crossed this.

    i did what both helpers said and it works perfectly.

    thank you
    thank you
    thank you
    thank you
Sign In or Register to comment.