Patch changes game version...Help!

I downloaded the newer version of Tribes 2. Then, I downloaded the patch from this site, multiple times. When I install the patch, my game version reverts to the old version. Why is this happening? What do I do to revolve it?


  • I still can't get the game working. When I install the patch, it changes the version of the game to the old 21570 from the new 25034.

    I saw where someone said to run the newest version of the game. Then, patch it. They mentioned changing the name of tribes2.exe.bak by removing the .bak. Change the name of the original tribes2.exe to something else so that the backup is now the file that is pulled up. I did this and it got me to the TribesNext opening graphic. However, there wasn't any functionality and the game froze.

    So, I tried installing the new version of the game, running the patch, and installing the new version of the game again without uninstalling. The patch changed the version of the game to the old version. The reinstallationI then added the new version's Tribes2.exe to the Tribes2.exe for the old version. So, I changed the name of Tribes2.exe to the new version from the second installation. The old version of Tribes2.exe I renamed to Tribes22.exe. Then, I ran Tribes and it started! It then prompted me to create a profile. When I did this, the game said I needed to patch, because I was using the wrong version.

    In conclusion, when I run the patch it causes my Tribes2.exe to revert back to the old version and give me the "Not a valid Win32 Application". When I don't patch it only tries to pull from the Sierra servers. When I install new version, patch, then install new version again, it gets me to the TribesNext online interface, but it doesn't allow me to create a profile. It states that the game hasn't been patched. So, the patch is doing something to the executable but is causing it to revert to the old version...sigh.

    Any thoughts?

    There are a
  • Where are you dling the game from?
Sign In or Register to comment.