addbots(); not working?

Hello everyone first I would like to say how happy I am about this project and I am glad to to be able to play tribes once again!

I am having an issue with the command addbots(); I get an error " (0): Unable to find function addbots"

Anyone have any suggestions? should I try using an admin mod?

I have been searching all day for a solution and have found nothing of use. Thanks for your help!


  • try typing
    it takes one argument to work (that tells the server how many bots to add.)

    Note: Adding bots to maps that do not have bot support will have unexpected results (most of the time they just stand there)
  • Thank you for the reply, but no matter what number I put in there I get the same result. Do you have any other ideas?
  • addbots is defined in aiDebug.cs within the scripts folder (line 727). Do have that file there?? (u should at least...)

    If you don't, check if its within scripts.vl2 also
  • I think we are getting somewhere with this. I have an aidebug.cs.dso in gamedata/base/scripts

    This file does not seam to be editable with notepad should I be using a hex editor or something?

    Also this fold does not exist until after the dedicated server is ran for the first time.

    In the gamedata/classic/scrpits folder there is a lot of *.cs files but no aidebug.cs

    Thanks again for helping me address this issue!
  • throw this file into your base/scripts folder and delete all of the .cs.dso in the scripts folder also. Then start up your server. Tell me if you get the same error. If you do, i got one more thing for you to do to prob fix whats happening.
  • Ok I tried using that file but it did not work.

    Every time I start the server it compiles new .cs.dso files

    Maybe I am launching the server incorrectly to make it use these .dso files?

    I am using C:\Games\Tribes2-tst\GameData\Tribes2.exe -dedicated to start the dedicated server.

    The version of the game I am using to host the server is a install from tribes2_gsi.exe with the TribesNext_rc2a.exe patch. Nothing else has been modified.

    Maybe I could record a log of what the server is doing on start up and send that to you?

    Thanks for sticking with me!
  • in ai.cs, make sure the first few lines are this:
    //        AI SCRIPT FUNCTIONS        //
    //first, exec the supporting scripts

    Then check server.cs and make sure "exec("scripts/ai.cs");" is in this file around line 72:
    exec("scripts/vehicles/vehicle_spec_fx.cs");    // Must exist before other vehicle files or CRASH BOOM
       exec("scripts/vehicles/vehicle.cs");            // Must be added after all other vehicle files or EVIL BAD THINGS

    If this does not solve it then I guess post a log of the server console. The error seems to just be saying that it can't find the command. This is prob because it isn't getting compiled (but it seems that it is).
  • I realized the reason I had no .cs files was that they where in the scripts.v12 zip file and needed to be extracted. So I extracted the .cs files and put them in the base/scripts folder and then checked all the info in your last post and made sure it was correct. I also deleted all the .dso files. I ran the server and still did not work. I will get back on this tomorrow.

    Thanks for all the help so far!
  • can you post a screen cap of when u enter addbots?? this might help (and are you running any mods?)
  • I will be at work and school all day today. I could send you a pm with the server admin password and you could check it out if you wanted to. I will get a screen shot up when I get a chance.

    the server name is [h2k] Tribes 2 Server
  • Only problem is admins can't execute console commands without some server-side command (which is not implemented on a base configuration)...
  • If you are running a dedicated server (server is a separate window) then entering addbots() in your game/client console will give you the " (0): Unable to find function addbots" error. You will need to run the command from the server console (the black window with all the crazy text).

    If you are running a listen server (hosting in-game) then you should not have any issue running the addbots() command in your console.
  • This was definitely the problem! Thanks for the help guys!
  • Ahh... I did not notice he was entering through his game console.... *face palm*
    All the signs were there.... lol
Sign In or Register to comment.