Did TribesNext Patch screw my game up?

I recently reinstalled Tribes II onto my gaming rig only to find out that the servers are no longer available...

Then I stumble upon TribesNext and a bit of excitement strikes. It's too good to be true! Now, for me atleast, it might be.

Tribes II was able to launch for me (Windows 7 Professional 32-bit), I'm able to go into Solo/LAN mode and I'm also about to launch Online but no servers are available. When I downloaded and ran this patch, I cannot even launch the game anymore! The TribesNext prompt comes up and says the following in a little, black box:

SierraUp Replacement 1.0 (10/31/2007)
http://www.tribesnext.com/
Launching Tribes 2...
Args: Tribes2.exe -online


And then a window pops up and says:

C:\Dynamix\Tribes2\GameData\Tribes2.exe is not a valid Win32 application.

What am I doing wrong? Any suggestions? Thanks!

Comments

  • ThythThyth Apotheosis Incarnate
    There's a FAQ entry covering this: http://www.tribesnext.com/forum/index.php/topic,721.0.html

    Please check the FAQ before making a support topic.
  • I have done so. I downloaded the included patch v25034 but I now receive the following error message when trying to update the game:

    The file C:\Dynamix\Tribes2\Readme.txt is not a valid previous version and could not be upgraded.

    And then it stops working. Any other advice?
  • ThythThyth Apotheosis Incarnate
    Scratches on the disk may also cause corrupted files/installation. Download the GSI and try again.

    As stated in the FAQ:
    If the above fails, you may have installed from a corrupt Tribes 2 installer (especially if you did not install from disc). Redownload Tribes 2 from a different mirror or, preferably, through BitTorrent and try re-installing.

    There are instructions in that FAQ topic on how to verify your copy of the GSI to make sure it wasn't corrupted.
  • I have downloaded the tribes2 cgi installation pack.

    When I play it, without applying the RC2A patch, solo & LAN works like a charm.

    But, the moment I install the RC2A patch, it gets a black screen and then it just crashes.

    My specs shouldn't be a problem, I normally play Tribes: Ascend on highest settings.

    I would really like to play "good ol' tribes" again, but it's a shame that it doesn't work.

    Is there some fix perhaps?
    Or any way I can make this work?

    Trying to download older RC2A patches didn't work out, because there are simply no seeders.

    Please help =)
  • I have downloaded the tribes2 cgi installation pack.

    When I play it, without applying the RC2A patch, solo & LAN works like a charm.

    But, the moment I install the RC2A patch, it gets a black screen and then it just crashes.

    My specs shouldn't be a problem, I normally play Tribes: Ascend on highest settings.

    I would really like to play "good ol' tribes" again, but it's a shame that it doesn't work.

    Is there some fix perhaps?
    Or any way I can make this work?

    Trying to download older RC2A patches didn't work out, because there are simply no seeders.

    Please help =)
    Make sure you read through the installation walkthrough exactly as stated. It sounds like you installed the game, started T2 up and closed it, then installed the patch. That could have led to problems...
  • edited March 2012
    no, actually...

    I first installed tribes 2, then applied the patch and had the black screen crashes from that moment on.

    Then after 3 times of uninstalling and installing the way it's supposed to, I tried something different.

    I thought that tribes 2 wouldn't work at all on windows 7, so I tried it without the patch.

    Then I found out that tribes 2 works like a charm, but that the RC2A patch screws it up :P
    It seems like the only way I can play tribes, is through lan xD Which I don't want :P

    So, any other solutions? =)

    P.S. Just found RC1E version =) The game starts, but the servers don't support it anymore >.> So I still can't play it, I need RC2A, but the same blackout problem persists =(
  • I get around all of this bs by running t2 on xp.
Sign In or Register to comment.