In Game Menus not appearing unless I mouse over - newer system

Hey everybody, I'm new here. T2 Vet just trying to play again. Downloaded the game client and then the patch as instructed to do so...installation went smooth but I have a problem when I run T2 Online. On game startup, The Garage Games logo shows up and then the Dynamix T2 movie shows, but after that none of the T2 interface/menus appears. I have to mouse over the screen for anything to show up and as soon as my cursor passes over it, the menus disappear immediately after my cursor moves.

laptop specs:
15.6 inch (1920x1080)
64-bit Windows 7 Premium
3rd Gen Intel Ivy Bridge 2.3-3.0 Ghz processor
nVidia Geforce GTX 675M 2GB w/ Direct X 11
8GB DDR3 1600 mhz dual chan memory

One thing to note is that when installing T2 I didn't install DIrect X 8 because I figured why Install DX8 when I have DX11 already...other than that I really don't know what's causing this issue and what I can do about it. If anyone else has had this issue or anyone knows what I can do to fix this, PLEASE help, I just want to play again =/ Thanks in advance guys

Has anyone else had


  • Hi
    Try disabling antialiasing in t2 as a game profile if enabled and if that doesn't help I've no clue off the top of my head. You will also probably want to disable threaded optimisation as well,. but that shouldn't have anything to do with not seeing menus. Hope this helps!
  • Also if you must have antialiasing try enabling fxaa for your t2 game profile in the nvidia control panel, fxaa works fine in t2 and has less of a performance hit than msaa or fsaa antialiasing.
  • I have the same problem on my computer, and I tried disabling antialiasing in nvidia control panel, but it didn't work.
Sign In or Register to comment.