Changing Resolution from default help. 4:3 or 16:9 all Janky

Hey Guys,

So I just recently downloaded Tribes 2 and the TribesNext patch. Super psyched to play again. The only issue I'm having right now is adjusting the game resolution.

The default is 800x600. I'm fine playing in a 4:3 aspect ratio with bars, however whenever I adjust the resolution the game window is completely thrown out of a wack and I can only see about half of what should fill the screen. I read about changing the DefaultFOV (?) from 90 to 16:9 in order to use Widescreen, but as soon as I start the game it reverts back to 90 and I have no luck with any resolution.

I tried doing some research and checking the forums but none of the information helped.

So I just wanted if this problem was common, how you resolved it (if you can), and what graphical adjustments do you make from the default. I imagine playing in 4:3 is more natural than a 16:9 stretched perspective.

Any help on being able to adjust the resolution in-game would be greatly appreciated. I actually really love the look of T2, although some higher resolution would be wonderful ;D ;D

Any recommendations on when to play and what servers to play on? Looking for some classic CTF experiences (if that happens?).



  • KrashKrash Neptune Sleeps
    The game natively supports widescreen resolutions (although if you're going for something like 4K you'll find the GUI components a bit small), and you should be able to select any standard resolution that the display driver reports your monitor supporting via the in-game options menu.
    Some people do also use scripts to alter their FOV, but I've personally not found it necessary unless using an ultrawide ratio.

    Can you clarify what you mean by "out of wack"? Is the scaling off (e.g. things too big/too small), portions of the screen black, or artifacting of some kind?
    What kind of machine are you running the game on, and are the drivers up to date? Do you have the game set to run in Direct3D or OpenGL mode?
  • Thanks for the reply. Sorry about the uninformative "out of wack".
    Yes, the scaling is way off. So when ever I changed the resolution from the default 800x600 the scaling is thrown off and I can't see much. The screen essentially zooms in and a large chunk is cut off. This goes for 4:3 or any other aspect ratio resolution.

    Nividia drivers are good of course. Overkill GTX 1070. Running in OpenGL.

    What resolution do you generally run the game in?
  • KrashKrash Neptune Sleeps
    Hmm... The only thing similar to what you're describing that I've seen was the first time I tried playing in 4K on an early Win10 beta build (see attached to compare to your issue); at the time there were no official GPU vendor driver packages released, and the Microsoft-provided one had a few quirks with OpenGL. Can't say I've seen or heard of anything like that since though.

    As I can't reproduce the issue you're having, two best guesses at the moment are that either there's some unusual miscommunication between the driver and the game as to the current context size, or for some reason the rendering context simply isn't being correctly switched when you're changing resolutions. In either case it'd be an odd glitch, but presumably fixable if it's able to start at the higher resolution without switching contexts.
    If you close and reopen the game after setting a higher resolution, does the problem still occur? If you're unable to exit normally after setting the res, I'd go into prefs/ClientPrefs.cs and manually set $pref::Video::resolution = "1920 1080 32"; (or whatever your desktop resolution is) before loading the game again.

    I'd also make sure to try running the game in windowed mode to see if the issue only occurs in fullscreen. The game only defaults to 800x600 only because it's a preference saved in a profile (the game used an early iteration of automatic settings based on your video card, which naturally hasn't been updated for recent devices); it's not hardcoded anywhere, nor is it what the game was really designed to use. There really shouldn't be anything preventing you from using a higher resolution.

    I don't load up the game nearly as much as I used to, but I typically just use a 1920x1080 window.
    • t2-4k.jpg
  • ThythThyth Apotheosis Incarnate
    Speculating, this effect of only drawing part looks like it could be related to screen resolution scaling factors on high DPI displays.

    It could be that the method used by the game to determine the window size (used for positioning and scaling UI elements) is getting a DPI scaled multiple of the real window dimensions.

    I don't have any high DPI displays on computers running Windows (just a retina MacBook Pro, and a couple of Linux running Chromebooks), so I'm limited in diagnostic capabilities. Windows 10 does have some advanced scaling controls in the Display settings; you could try playing with those too.

    Also, as Krash suggested, try running in windowed mode. The graphics initialization for full screen mode is more complex, and more things tend to go wrong.
  • KrashKrash Neptune Sleeps
    edited February 2019
    Speculating, this effect of only drawing part looks like it could be related to screen resolution scaling factors on high DPI displays.

    Ahhh, yeah, come to think of it, this is almost certainly the case if yours looks similar to the shot I posted. It completely slipped my mind that I'd had to disable it due to similar issues on other applications, but the scaling factor absolutely would cause issues with how the game determines the canvas size... and potentially also have problems with mouse input clipping.

    I believe you can disable this setting on a per-application basis if you'd prefer not to set it system-wide: try finding "Tribes2.exe" in your GameData folder, right-clicking on it, and under the compatibility tab click "Change high DPI settings". If you set the scaling override option at the bottom to have the scaling performed by the application, it should prevent this from happening.
  • KrashKrash Neptune Sleeps
    Did a bit of testing over lunch and confirmed that it was indeed DPI scaling at fault in that case; where the game is requesting quite a large window, the one it's being given is actually substantially smaller than the selected (and assumed) resolution.

    I wrote a little patch (see attachment) which you can extract in your Tribes2\GameData\ directory to prevent the game from exceeding the window given to it... however I don't necessarily recommend using this over simply disabling DPI scaling for the application. Effectively, when DPI scaling is active and the game is in fullscreen, this patch will force the game canvas to fit the size of its window (e.g. at 200% scaling, if you select 3840x2160, the game will run at 1920x1080).
    This may be useful if you otherwise have difficulty reading the UI text, but the 3D content will also be rendering at the lower resolution, so it won't necessarily be pretty on a larger screen. Assuming you're using a laptop screen or reasonably sized desktop monitor, it should look halfway decent.

    Of course, this is just a quick experimental patch: no guarantees whatsoever.
Sign In or Register to comment.