Spinning Mouse

Ok so i having some serious mouse issues... everything in the menues works fine but as soon as i get to any in game action all of my mouse actions just make my view spin and look upwards, like any clicking or moving just makes me look up and spin to the right..

I dono what would be the issue on this one but if you can think of anything let me know.. i am running it in 32 bit mode one a quad core 64 bit system with with vista but i dont think that is the issue cus everything else works just fine mabey it has somthign to do with my mouse drivers?

... thanks for the help..


  • Did you perhaps try bringing down the mouse sensitivity?

    In game as well as at the system Control Panel?
  • There is a Direct Input toggle option in the game settings. You can try toggling that and see if that fixes your problem.
  • k so i tried the toggel and turning the sensativity down... the toggle did nothing... and changhing the sensativity just made it spin slower... i tried updating my drivers... but they are already as good as they can get.. i dont know wtf is wrong with it
  • Re-install Tribes2 make sure the Tribes2 folder is gone before installing it. if that dosent help i dunno what to do...
  • Do you have issues like this with any other game? You might try setting affinity, and also setting vsynch to enabled.
  • K i fixed it... i had to uninstall it and delete the tribes 2 folder ... and delete the temporary install floder , once finished that i re installed and it only works on 16 bit depth
  • For what it's worth, in case anyone else comes up with this thread in search results.

    I'm running Windows 10/64 build 1709 and the "spinning mouse" issue with Tribes 2 affected my computer, as well.

    In the default installation, under Settings > Controls, the toggle for "DINPUT MOUSE" is not enabled. By filling this checkbox, the spinning mouse issue stopped.
  • I also fixed this issue by toggling my Direct Input setting.
  • Its the windows 10 creators update

  • I also fixed this issue by toggling my Direct Input setting.

    This fixed my issue as well, thanks.

    No idea why I didn't try that myself.
Sign In or Register to comment.