TribesNext

Welcome, Guest. Please login or register.
Did you miss your activation email?


TribesNext >  TribesNext.com Forums >  Tribes 2 >  Mods and Customization >  Renegades Mod Files are in here enjoy all Original files from renwerx.com « previous next »
Pages: [1] 2 Print
Author Topic: Renegades Mod Files are in here enjoy all Original files from renwerx.com
Maiwand
Nugget
Posts: 12

View Profile
December 09, 2014, 09:39:47 PM »
Whoohoo!! I found all the original Renegades Mod Files from the Original Renwerx.com Website. I was driving home and was thinking how can I find the origianl files from the Renegades Mod for Tribes 2. I was wonderering if anyone caches old websites including the files I know it was a real real slim chance. When I got home I searched and Bam I don't know how I found it but this service not only cashed the old Renwerx.com Website it also cached it's files. YES ALL Renegades Mod Files. I uploaded all of them to my Google drive so here you go I hope you all Enjoy this.

Following Files Listed Below   Download All files  zip https://drive.google.com/uc?id=0Bw2kTwAnwA__aFFDUlh5RmF6bGM&export=download

Server Files:

Renegades 2.1b Update Server
Renegades 2.0b Server EXE With Desktop Icons
Renegades 2.0b Server EXE No Desktop Icons
Renegades 2.0b LINUX Server
Renegades 2.0A Server EXE Without Desktop Icons
Renegades 2.0A Server EXE With Desktop Icons
Renegades 2.0A Server Linux
Renegades 2.0 Server EXE Without Desktop Icons
Renegades 2.0 Server EXE With Desktop Icons
Renegades 1.0A Server EXE

Renegades Client

Renegades Client Pack v4 Windows
Renegades Client Pack v4 Linux
Renegades Client Side Pack v093 Windows
Renegades Client Side Pack v093 Linux

Renegades Map Pack

TWL Final Pack
X2 Map Pack
Maiwand
Nugget
Posts: 12

View Profile
1: December 10, 2014, 12:45:58 AM »
I'm about to give up. Every time I run a dedicated server with the Renegades mod I get a UE I have no idea what's going on. I know Renegades mod worked after the last tribes patch. The only thing I can think of the reason the server is crashing is Because I'm running Windows 7 x64. I even tested this without the router and windows firewall off.  IF anyone knows how to run this mod on windows 7 please share your steps. I'm all out of ideas......... LETS SEE WHO CAN RUN mod on windows 7 with a Dedicated SERVER.
rJay
Scout

Posts: 396

View Profile
2: December 11, 2014, 12:07:38 AM »
I have 8.1 so I can't properly test it.

Romans 1:16
GeEkOfWiReS1097
Nugget²

Posts: 73

View Profile
3: December 13, 2014, 12:03:26 PM »
I'm about to give up. Every time I run a dedicated server with the Renegades mod I get a UE I have no idea what's going on. I know Renegades mod worked after the last tribes patch. The only thing I can think of the reason the server is crashing is Because I'm running Windows 7 x64. I even tested this without the router and windows firewall off.  IF anyone knows how to run this mod on windows 7 please share your steps. I'm all out of ideas......... LETS SEE WHO CAN RUN mod on windows 7 with a Dedicated SERVER.
Let me see what I can come up with later today.
EDIT: Worked for me... connected and played a little.
« Last Edit: December 13, 2014, 12:17:11 PM by GeEkOfWiReS1097 »

If your problem can't be solved, you haven't dug deep enough.
Avoid re-posting a question that has been answered and we can prevent forum clutter:
Search with me.
Blakhart
Juggernaught
Posts: 1625

View Profile
4: December 13, 2014, 01:00:19 PM »
Over the lan or wan? Dedicated or listen server?
GeEkOfWiReS1097
Nugget²

Posts: 73

View Profile
5: December 13, 2014, 01:28:35 PM »
Dedicated on both Windows 7 and 8.1 setup to run on port 28000, which was open.

If your problem can't be solved, you haven't dug deep enough.
Avoid re-posting a question that has been answered and we can prevent forum clutter:
Search with me.
Doc34thfist
Nugget
Posts: 2

View Profile
6: September 07, 2017, 03:53:13 PM »
Please Fix the download and give credit to the Original Renwerx Team.  If you have the source you can see the names listed in the code.
They worked hard on the mod and deserve the credit.  Lol the image you have of the site I remember making that page.
rJay
Scout

Posts: 396

View Profile
7: September 07, 2017, 04:41:15 PM »
Credit is still very important, no matter how few players comparatively play the game anymore.

Romans 1:16
Infernus
Nugget
Posts: 12

View Profile
8: January 21, 2018, 09:51:49 PM »
Test
HybridSin
Seņor Nugget
Posts: 139

View Profile
9: January 23, 2018, 03:17:19 AM »
1 2
Chocotaco
Nugget

Posts: 41

View Profile
10: January 24, 2018, 11:21:45 AM »
Hello TribesNext,

We've been trying to get a Renegades server going and got it all set up with Tricon but keep getting a UE 00559ce2 about 10 sec after the server has completed loading.

Did some digging and its a reference to something to do with networking...
here http://www.tribesnext.com/forum/index.php?topic=1715.0;prev_next=prev
and here https://www.tribesnext.com/forum/index.php?topic=3567.0

We've made sure dsos in base/classic were deleted, not renegades folder as specified. SetHighPerf(0), did the blank ChatGUI.cs thing, did the t2_lan_fix.cs thing, read all we can about it.
Made sure specific ports are indeed open.
We've run it in windows server 2016 and my linux vps with no luck.

Without digging too much has anyone experienced this or have any suggestion to a solution to this issue.
Im also attaching a wine dump of the error when it crashes in wine.
Attached files
* backtrace.txt (6.3 KB - downloaded 41 times.)

Krash
Administrator
Posts: 257

View Profile
11: January 25, 2018, 06:14:30 PM »
00559CE2 specifically refers to a procedure handling asynchronous responses to a DNS lookup through the WinSock library; on Wine, my guess would be that for whatever reason it's not able to connect to a nameserver defined by the system, or it's getting an invalid response somewhere along the line.  In principle you could run it with WINEDEBUG=+winsock to see if there's any useful output to determine where the problem hits, and work out from there.
I haven't run it under Wine myself in years, and didn't have the same issue the last time I did, but the game has been known to have problems with TCP connections in Linux in the past -- I believe something a few people resorted to in working around it was just  to disable the standard heartbeats and create a cron job to hit master.tribesnext.com/add/28000 every 15 minutes.  

You shouldn't really be getting the same error under Windows unless it has no usable connection/nameservers.

edit: Of note, I just ran a fresh install on a clean VM with Ubuntu-16.04+Wine-3.0 and was able to get a server running without issue not having changed anything from the defaults.
« Last Edit: January 25, 2018, 07:16:14 PM by Krash »

Infernus
Nugget
Posts: 12

View Profile
12: January 25, 2018, 06:33:23 PM »
The same exact problem occurs with Windows.
Krash
Administrator
Posts: 257

View Profile
13: January 25, 2018, 07:13:48 PM »
If that's the case, you'll want to check your network configuration; again, this specific error only occurs if there is an unexpected failure during a name lookup.  If you have multiple NICs, you might need to explicitly specify $Host::BindAddress to get it on the right adapter, but outside of that it'll only be attempting to use what's provided to it by Windows.

Infernus
Nugget
Posts: 12

View Profile
14: January 25, 2018, 08:16:47 PM »
Krash, Choco and I have tested this on 4 different machines, some Linux and some Windows. We've found that it has nothing to do with the OS or IP settings on the NIC. There is only a single NIC on the test machines. When we do a vanilla install of Tribes 2 (without the RC2a patch), we are able to run a Renegades server just fine without crashing. The moment we install the RC2a patch and run the Renegades server, it crashes after about 10 seconds with that UE. This is the same symptom reported by the OP.
Pages: [1] 2 Print 
« previous next »
Jump to:  

irc.quakenet.org / #TribesNext Powered by SMF  © Simple Machines