Notice of forum updates

KrashKrash Neptune Sleeps
edited July 2020 in General Discussion

As you've probably noticed, things have changed a bit: out of necessity, the old SMF forum is being moved over to new, actively maintained, software.

This one is still far from perfect, and there are still more than a few notable issues with our theme here, most of which will most likely be addressed in the coming weeks/months when there's time to do so, but for the most part the forums should now be in better shape than before. I'll also be doing an update to the main page and add a bit more flavour for showing servers and other Tribesy things eventually.

A few quick example issues that'll probably be fixed at some point:

  • Some things are... quite big. Others, maybe too small.
  • Forms on some pages may lack solid backgrounds
  • Some buttons/menus can become unresponsive after a state change (e.g. the edit button on a post may not work immediately after editing a post)
  • Some images and branding may be missing
  • Navigation could be improved
  • The sidebar/drawer is janky but currently necessary for navigation and inputs on some pages
  • If you haven't logged in in over 10 years, it's possible you may need to do a password reset
  • It likes to load about twice as many scripts/stylesheets as should be needed, but it should be possible to trim those down

If you notice anything especially bad/broken, please report it here or send a private message (or email support [at] tribesnext.com).

The logo is a work in progress and may change.

Comments

  • ThythThyth Apotheosis Incarnate

    Swanky.

  • edited July 2020

    It looks pretty modern, nice! And the logo's pretty cool. I personally liked the old forum as well.

  • KrashKrash Neptune Sleeps
    edited July 2020

    The old forum was unfortunately a few years past its best before date, so it was up to the point where it wouldn't really have been a good idea to keep running anymore.

    Now, having put a few weekends into getting everything exported and converted to their formats and working with Vanilla code, I wouldn't say it's the most ideal solution out of the box either... but having compared it to a handful of other options, the only alternatives I was satisfied with (or had more benefits to their use) were going to require a commercial license and/or an additional VM dedicated to running the forums. If we were handling considerably more traffic I'd probably have taken on that expense, but for what we actually need it didn't seem like there'd be much of an advantage.

    In any case, as long as it's basically working now and we have everything archived and searchable (and maintainable!), we're probably in a pretty good spot.

  • edited July 2020

    Well, I wouldn't want to be the guy to transfer all the old data to this new forum software. Must've been a real pain in the ass. I don't really have any complaints about this new forum, now that I think about it. So I suppose it's a success if you ask me.

    Maybe, at some point, I'd like a counter showing how many times images were viewed, files were downloaded, and also when the files were last updated. That'd be nice. And a section showing just posts with files attached, like a download section, with the ability to sort by popularity and date. Anyway, I'm just rambling. It's great that it got updated to a more modern software and it's working.

  • KrashKrash Neptune Sleeps

    The attachment date would be fairly easy to display, download counts possibly a little less -- right now this system simply isn't currently tracking new views in the database (the old counts are still backed up), but I believe it does still do some routing that could be hooked into to add it.

    A files section isn't out of the question, and ideally we'd even love to preserve as much of the content that's been made for the game over the years as possible, but it's definitely something of a larger project to consider.

  • Sounds pretty good then. I also forgot to ask, where can I set a signature? Or is that not implemented yet?

  • KrashKrash Neptune Sleeps

    No signatures for now. Maybe later, but they're a bit of a hassle to deal with, and add an insecure/mixed content warning to the page every time they include images linked from insecure sites.

  • Sweet! It's cool to know that you guys are maintaining the site still, even down to updating it with a new logo. Color scheme is still nice too.

  • I haven't know this site was available. I am really hoping that this is still active and that there are occasions that folks still get together and play. I am the original METALHEAD from T1 and was <RD>METALHEAD (it may have been THEMETALHEAD not sure been a long time) If not, maybe we can set up 1 day a month that we all get together and play? I have limited bandwidth but I can make sure I am ready. Here's hoping someone hears this.

    METALHEAD

  • KrashKrash Neptune Sleeps
  • edited April 16

    I get an internal server error when I'm trying to post in this thread: https://www.tribesnext.com/forum/discussion/4021/classic-bots-v1-3-69

    In addition, I was editing the first post in that thread a bunch of times until my edit had to be approved. Could the number of edits be increased before editing requires admin approval?

  • KrashKrash Neptune Sleeps

    I think the flood/spam control you ran into assumed they were new discussions, which was set to like 3 within 60 seconds and a 2 minute block if you passed it. Didn't realize they applied that same check to edits, but it's adjusted a bit now.

    You've also been set to verified, so it should bypass those spam checks for you.


    Not sure what triggered the server error, could be one of a few things, but would have to dig into it to find out. Most likely a one-off issue.

  • Thanks! Editing works now. Though I still have some issues in that thread with the internal server error. There was a draft saved with the first word misspelled. I tried correcting the draft and then posting it but I got the IS error message. So I just posted it with the spelling mistake and it worked. But now it won't let me edit the mistake in that post. Well, no big deal, I hope it's a one time thing.

  • KrashKrash Neptune Sleeps
    edited April 18

    Hmm. I suspect that could be an issue with the BBCode parser on legacy posts -- there wasn't a lot of testing on editing them when adding compatibility for (most of) the features from the old forum formatting, just on making sure they rendered more or less correctly. Seemed to work fine when I tried editing that post though, so it may have been something in your draft or session that tripped it up.

Sign In or Register to comment.