TribesNext

TribesNext.com Forums => Support => Topic started by: The | Policeman on August 30, 2018, 11:19:06 AM



Title: Slow Tribes
Post by: The | Policeman on August 30, 2018, 11:19:06 AM
Hey all, Policeman here aka nutty, been a while since playing and i decided to re-download and play on my laptop. Currently when it launches the client acts super sluggish and cant barely even navigate the cursor. I used to play Tribes 2 on this very laptop back in the day so I'm not sure if my laptop is crapping on me, but I'm able to play League currently just fine so I'm not sure why it's so sluggish with T2. Thanks for any help whoever is still out here! :)

some specs on my laptop are

Windows 10 64-bit
Intel Core i7-2630QM CPU @ 2.00 Ghz
6.0 GB RAM
Intel HD Graphics 3000


Title: Re: Slow Tribes
Post by: Krash on August 30, 2018, 11:41:26 AM
A machine with those specs shouldn't have any trouble running the game -- it's possible you may be running in D3D mode, which tends to be pretty slow.  If possible, I would go into your video options in-game and set it to use the OpenGL renderer.

If you don't see the option, you will want to open prefs/clientPrefs.cs in your favourite text editor and make sure the following lines are set:
Code:
$pref::Video::allowOpenGL = "1";
$pref::Video::displayDevice = "OpenGL";


Title: Re: Slow Tribes
Post by: The | Policeman on September 01, 2018, 10:09:19 AM
Hey Krash thanks for the reply,

So I checked my ClientPrefs for those 2 lines of code and they are the same as what you provided.

Ill try to provide more information but its kinda hard to describe what exactly is going on. It seems like right after the game launches the fps is around 2 or some type of lag/ delay is immediately occurring. It takes like 3-5 seconds for the monitor to display where I moved the mouse and is nearly impossible to even navigate through login. Hope that helps more.


Title: Re: Slow Tribes
Post by: Thyth on September 01, 2018, 10:54:57 AM
You could try setting displayDevice to "D3D" instead of "OpenGL" and/or trying to switch between fullscreen and windowed modes (there should be a $pref:: value that says either fullscreen or windowed in the same file).


Title: Re: Slow Tribes
Post by: The | Policeman on September 01, 2018, 12:07:31 PM
Switching it to D3D worked for me!  Thank you Thyth and Krash!